Forumsee logo
Forumsee » Hardware » Computer Components » Read message
RSS: Subscribe to RSS

Water cooling bad temps

Water Cooling - www.overclock.net
Hello,

Yesterday I finished my first water cooling setup for my 2xGTX 580 and i7 920.

The thing is that when PC is under load (stress testing) temps rise very fast.

For example I turned on Fur Mark and GPU temp went from 62 C idle to 92 C in few seconds. Basically the same story with CPU and Prime 95.

GPU blocks are not full cover but memory and VR-s are cooled with a plate that was left from stock MSI cooler.

I have a 360mm rad and 500l/h pump. I can see water flowing from reservoir.

What could cause temps rising rapidly? Weak pump? I can not see any air bubbles as well.

Loop scheme: reservoir >pump>rad>cpu>gpu1>gpu2>reservoir '); }


Read responses in overclock.net

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
A History of Nvidia GeForce
A History of Nvidia GeForce
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more