Forumsee logo
Forumsee » Hardware » Computer Components » Read message
RSS: Subscribe to RSS

Trouble loading windows 7 on Asus z270 Pro4

Intel Motherboards - www.overclock.net
Hey OCN,

So to start, I'm clumsy and tripped over my tower and my knee landed right on my old CPU cooler which is likely why I'm having this problem in the first place. After replacing that board and CPU cooler in my main system, I'm attempting to Frankenstein a rig together with the board that I've likely destroyed.

Here's where it gets confusing. I was able to boot into a windows install I had on an old SSD using that board but the only USB item that would work in windows was my keyboard. My mouse and wireless internet adapter wouldn't register but were definitely getting power since the LED's lit up. So I tried doing a reformat and fresh install of windows 7 and the mouse and keyboard both worked perfect in the UEFI BIOS and through the reformat process until it rebooted and prompted me to name my computer at which point both the mouse and keyboard are completely unresponsive. Everything is plugged directly into the motherboard.

System specs:

Asus z270 Pro4

Pentium G4400

EVGA GTX 1070

corsair DDR4 2400 8GB (1x8)

corsair RM1000x

corsair force LE 480GB SSD


Read responses in overclock.net

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
A History of Nvidia GeForce
A History of Nvidia GeForce
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-backend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more