Forumsee logo
Forumsee » Hardware » Computer Components » Read message
RSS: Subscribe to RSS

SGI Multilink Adapter

Recapping Your Motherboard - Badcaps Forums - www.badcaps.net
So I picked up a known not working SGI MLA adapter for a 1600SW SGI panel (I know this works, tested on a SGI O2) a few weeks ago. The adapter lets you use a 1600SW panel with DVI input.

The guy I got it from was going to chuck it in the bin but I thought I'd see if I could see anything wrong on the pcb as usually these suffer from blown mosfets. The mosfets appear fine and unit powers on but produces a solid red status led.

There was however a dodgy looking three-legged component (suspect a paired diode?) that looked like it's coocked. The plastic package has burnt and bulged in the middle. I can only make out a 'Z' on the left of the package.

Any ideas how to obtain the specs of this component or source a replacement?

Thanks in advance.


Read responses in badcaps.net

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
A History of Nvidia GeForce
A History of Nvidia GeForce
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-backend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more