Forumsee logo
Forumsee » Hardware » Desktop & PC » Read message
RSS: Subscribe to RSS

Samsung 860 EVO 4TB SSD no...

Dell Computer Forum - forum.desktopreview.com
Not sure if this is a place to ask for tech support (please direct me to a better place to post if not allowed here), but... I had a Samsung 860 EVO 4TB SSD installed in my HP EliteBook 820 G4 on the SATA port. It was running Windows 10 flawlessly for 3 months until I updated the BIOS last night and the BIOS no longer recognizes the SSD. I tried rolling back the BIOS to the previous version but it still won't recognize the drive. I took the drive out and put it into an another older HP EliteBook and that computer doesn't recognize it either. Any ideas why my SSD isn't being recognized anymore?

A spare 500gb HDD that I had lying around is still recognized by both laptops when installed into the same SATA slot.

After running the hardware diagnostics via the BIOS, this is what it says when the drive *is* installed on the SATA slot:


Read responses in forum.desktopreview.com

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
A History of Nvidia GeForce
A History of Nvidia GeForce
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more