Forumsee logo
Forumsee » Hardware » Computer Components » Read message
RSS: Subscribe to RSS

Metallic, distorted sound when headset in use only

Sound Cards and Computer Audio - www.overclock.net
I ran into an odd issue as of late and hope you might be able to help me identify the root cause.

Roughly a week ago when I booted up my machine I noticed extreme metallic, distorted sound coming out of my headset (Sennheiser PC360).

I tried a couple of things and here are my findings so far:

- The same kind of messed up sound comes out of my (cheap stereo) boxes for as long as the headset is plugged in additionally, if I only have the stereo boxes plugged in the sound is fine (also both front or rear work)

- It doesn't matter if I use the 3.5 mm jacks on the front or rear - both give the same result

- Using another 3.5 mm jack headphone or even simple earplugs also give the same sound

- Checking only for similar cases more often they recommend checking the DPC latency which i did but can kinda rule out as usually at/below 500 ?s

- Also reinstalling drivers didn't do anything

I am rather close to reinstall W10 to rule software out as cause at that point. '); }


Read responses in overclock.net

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
A History of Nvidia GeForce
A History of Nvidia GeForce
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more