Forumsee logo
Forumsee » Hardware » Laptops » Read message
RSS: Subscribe to RSS

Mecer m77cu no display

Troubleshooting Laptops & Notebooks - Badcaps Forums - www.badcaps.net
19v 4.7amps system spec

Tested by changing ram around and also 1 at a time.

Tested hdmi to standard monitor nothing.

Removed battery hard reset nothing.

Removed bios battery then powered on nothing inserted powered on also nothing.

Found few caps near the display area and in the same area on otherside of the board its gpu processor.

with a multimeter buzez both sides of the caps.

I connected dc power supply set to 5v 3.xx amps to 4.xxamps used freeze spray and i can se were the heat area is its just near them super tiny caps.

Need your suggestions what to do or to recheck different way to make sure its short.

How do i 100% determen caps is gone


Read responses in badcaps.net

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
A History of Nvidia GeForce
A History of Nvidia GeForce
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more