Forumsee logo
Forumsee » Hardware » Desktop & PC » Read message
RSS: Subscribe to RSS

No display asrock x370

PC Hardware and Components - forums.hexus.net
This is my new build:

Ryzen 5 1600

Asrock x370 gaming k4

Corsair vengeance led 2x8gb 3200

Nzxt x62 cooler

Crucial 480gb ssd

Evga 650 g2

Problem I've got is there is no display coming up, can't even see the bios. I've tried connecting it via the hdmi slot on the mobo. Tried it in the TV and my 27" Asus monitor. I've also tried installing a copy of Windows 7 from my other pc and connecting it to the new one but still don't get a display. There is a code on the mobo with AE on it. Do i have to have a GPU connected to do it? I've also tried one ram stck in at a time and still the same . Any ideas


Read responses in hexus.net

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
Life Videos Youtube
Life Videos Youtube
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more