Forumsee logo
Forumsee » Hardware » Networking » Read message
RSS: Subscribe to RSS

Connecting as WPA2/AES with wifi using mixed mode...

Networking - AnandTech Forums - forums.anandtech.com
So, apparently my building's wireless uses mixed mode, I even saw a screenshot of the settings, but every device I have connected (iPhone 7 Plus, Galaxy S III, and my PC c. 2011) goes to WPA-personal. Noticed thanks to the iPhone's security recommendation.

I would expect iPhone would choose WPA2 if available, likewise the rest. Could something be awry?

Also, it's dual-band, and 2.4 Ghz is quite slow vs 5 Ghz, I know, it could be interference, but also, TKIP defaults to wireless n from what I read, and tops out at 54Mbps.

They have mixed mode for more devices to work, which I get, but WPA2 has been around since 2004, so, would it be reasonable to ask them to have just the 5Ghz on WPA2/AES perhaps?

Thanks for advice/input!

 


Read responses in forums.anandtech.com

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
Life Videos Youtube
Life Videos Youtube
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more