Forumsee logo
Forumsee » Hardware » General » Read message
RSS: Subscribe to RSS

Can't launch programs/task manger after plugging in X52 Pro

Windows 7 Drivers Forum - www.tomshardware.com
Hello All,

I recently purchased an x52 Pro. After installing the drivers included on the disc, later updating to the latest drivers from their site, every time I connect it I lose the ability to launch programs or even task manager. Than when I try to restart it get's the the Shutting Down... screen and just sits there. I've tried to re-install the drivers but during the install I need to connect the x52 and as soon as I do the program just hangs at installing drives. I haven't had this issue with any other USB devices, and my computer operates normally until I plug in this device. I've checked for viruses/malware with Rkill, malware bytes and have BitDefender installed.


Read responses in tomshardware.com

Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
Life Videos Youtube
Life Videos Youtube
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more