Forumsee logo
Forumsee » Hardware » Computer Components » Read message
RSS: Subscribe to RSS

Anyone else finds Windows 10 to...

Computer Storage Forum - forum.desktopreview.com
Getting a bit frustrated with Win 10 on my Xeon E3-1575M with AMD W5170. I don't do any graphics work, my only need for the machine was for the ECC memory (I run a big fat ERP SQL package on it).

Anyway, things I have noticed over the last few weeks:

- Numerous crashes/restarts of Windows Explorer. Totally random and highly disruptive. Laptop restarts help.

- As a result of the above, search Windows function is intermittent. Highly annoying.

- Can only work with switchable graphics turned off. Otherwise I see all sorts of weird desktop behaviour with AMD graphics card driver crashing.

- Forget about connecting an external monitor (Dell as well) to a display port. Windows Explorer/Graphics card can't handle it. All of the above behaviour, times 10. Found a work around. Have to restart the laptop 2-3 times in a row in order for it to work stable.

- Disconnect the monitor at the end of the work day, go home, start the laptop again (no monitor at home) - same behaviour. 2 restarts and it goes back to normal mode. Kind of needs restarts to get used to the idea it has or hasn't got the monitor attached to it.

- Lately, it fails to start. Won't go past the Dell icon. Upon hard reset it starts the Windows up and AMD driver reports the settings have been reset to their defaults after a fatal crash.

The laptop has 16GB of Dell ECC memory. I've put a 1TB intel PCI-e drive in it which is where OS is installed.

I'm a system admin in the past and know my hardware quite well (servers mostly and command line). I'm ready to switch to Linux (which I hate with passion) or Windows 7. Only installed 10 to future proof the ERP package and run a XP in Hyper-V. I ran Macs for the past 12 years and if the goodam Apple didn't botch their latest Macbook I'd never get myself involved with Windows as my main OS again but it's too late now so have to do best with what I have.

A bit of a rant really as I will have to find the time and install the 7 or if the reports are positive may switch to Linux and run ERP in Xen/KVM.

Thanks for your time reading this.

 
Date: Jan 11, 2017   


Last videos:

Acoustic Delay-line Memory
Acoustic Delay-line Memory
Fake temps? Skeptic of SC new build
Fake temps? Skeptic of SC new build
Nice review on 8600k
Nice review on 8600k
VEGA 64 FPS
VEGA 64 FPS
internet growth question
internet growth question
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Thermal paste 'upgrade' to GPU's...worth the hassle?
Thermal paste 'upgrade' to GPU's...worth the hassle?

Cars ·
Travel ·
production-frontend