Forumsee logo
Forumsee » Hardware » General » Read message
RSS: Subscribe to RSS

Moved my computer and now monitor NO SIGNAL help pls !

Hardware Clinic - www.hardwarezone.com.sg - forums.hardwarezone.com.sg
Basically i shifted my computer. Plugged evergthing in and im fxxxed !! I am using a asus monitor. I have tried many ways but to no avail. Going crazy soon lol. When i first bought the monitor i has trouble operating it too but somehow after a few restarts it worked. As for now i have tried for 3 hrs. The cpu is running fine as all fans are working my keyboard and mouse and monitor has power but no signal. Computer is booted up as i can use both caps lock and num lock keys.

I have unplugged all wires press the power button for 1 min and power it on.

I have removed reinstalled the cmos battery

I have removed and installed my ram

I have changed my new hdmi cable.

Expertd please help !!
Date: Jan 9, 2018   


Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
Life Videos Youtube
Life Videos Youtube
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more