Forumsee logo
Forumsee » Hardware » Computer Components » Read message
RSS: Subscribe to RSS

External USB amplifier, electrical/incompatibility problem (maybe)?

Components Forum - www.tomshardware.co.uk
Hi, I have a strange problem here. I bought an usb amplifier, Epiphany O2/ODAC, and I was enjoying until I bought a new video card (Sapphire 7970 Dual-X). From then the amplifier is started getting crazy, sometime it just turn off itself and can't be turned on with the switch, it's just dead. Some other days (not many actually) I can use it normally and turn it on/off by switch. I tried two 7970 and a 280x video card, I changed my whole system (except the PSU, is a Thermaltake ThoughPower XT 775W) but the problem is still there. I have to mention that the amplifier have it's own AC and when I plug it in a different power point (far from my pc) the amplifier run normally. Is the amplifier incompatible with video cards? Or is a power/electrical problem?
Date: Jan 20, 2014   


Last videos:

Steelseries Rival 600
Steelseries Rival 600
Replacing Nvidia 980M with GTX 1070
Replacing Nvidia 980M with GTX 1070
Instrumental request :)
Instrumental request :)
Intel Optane 900d
Intel Optane 900d
Old Machine Mod
Old Machine Mod
Occasional problem with YouTube on desktop Windows
Occasional problem with YouTube on desktop Windows
Pump Resivour
Pump Resivour
Life Videos Youtube
Life Videos Youtube
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more