Forumsee logo
Forumsee » Hardware » Networking » Read message
RSS: Subscribe to RSS

Slow WAN connection on Win7 on 1 computer

Networking - AnandTech Forums - forums.anandtech.com
I have a Win 7 machine (Dell 660S) that when I go to testmy.net I get 39Mbps down and it's always been pretty rock solid in the past at around 115Mbps. I have a 100Mbps internet connection.

I started by testing all the usual things (new cable, different port, deleted/reinstalled driver). At that point I thought maybe the card was going bad but I decided to try one more thing. I ran Linux off a USB stick and bingo speeds were at 115Mbps.

Before I reinstall 7 is there anything I can do to troubleshoot this to figure out where things are going bad?

Also, all my other machines on this network both wired and wireless easily are in the 110Mbps to 120Mbps range using testmy.net. If I use dslreports.com/speedtest I DO get a speed of 120Mbps on the Dell but that is a multithreaded test and from what I've heard not as good an indication of true speeds. If any of that makes a difference in figuring this out.

 
Date: Apr 21, 2017   


Last videos:

How do I Create an Intranet Based on a Youtube Video.
How do I Create an Intranet Based on a Youtube Video.
Google Assistant is out for Shield NOW, Sony TVs to follow!
Google Assistant is out for Shield NOW, Sony TVs to follow!
Hide any folder from computer without software
Hide any folder from computer without software
i5-6600k, GTX 1060 6g random...
i5-6600k, GTX 1060 6g random...
i5-6600k, GTX 1060 6g random...
i5-6600k, GTX 1060 6g random...
i5-6600k, GTX 1060 6g random...
i5-6600k, GTX 1060 6g random...
Hauppauge HD PVR 2 video blurry...
Hauppauge HD PVR 2 video blurry...
Youtube 8k
Youtube 8k

Cars ·
Travel ·
Pets ·
production-frontend